web-dev-qa-db-ja.com

「既に存在するプログラムの種類」とは何ですか?

私のプロジェクトをビルドしようとすると、このエラーが発生しました

プログラムの種類が既に存在する:Android.support.v4.accessibilityservice.AccessibilityServiceInfoCompat Message {kind = ERROR、text =プログラムの種類が既に存在する:Android.support.v4.accessibilityservice.AccessibilityServiceInfoCompat、sources = [不明なソースファイル]、ツール名=オプション。 of(D8)}

私はスタックオーバーフローで解決策を見つけることも助けにはなりませんでした。ここに私のbuild.gradleファイルがあります

    apply plugin: 'com.Android.application'Android {
compileSdkVersion 28
defaultConfig {
    applicationId "com.example.hassan.qrscan"
    minSdkVersion 18
    targetSdkVersion 28
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
    }
}}dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
//noinspection GradleCompatible
implementation 'com.Android.support:appcompat-v7:28.0.0-alpha1'
implementation 'com.Android.support.constraint:constraint-layout:1.0.2'
implementation 'me.dm7.barcodescanner:zxing:1.9'
implementation 'com.journeyapps:zxing-Android-embedded:[email protected]'
implementation 'com.Android.support:design:28.0.0'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.Android.support.test:runner:1.0.1'
androidTestImplementation 'com.Android.support.test.espresso:espresso-core:3.0.1'}
6
Hassan Fayyaz
 implementation 'com.Android.support:appcompat-v7:28.0.0-alpha1'

依存関係のバージョンをダウングレードします

 implementation 'com.Android.support:appcompat-v7:27.1.0'

また、設計の依存関係を追加します

 implementation 'com.Android.support:design:27.1.0'

これが私のために働いたらそれをチェックしてください

2
harsh

プロジェクトに繰り返しライブラリまたは異なるバージョンの同じライブラリがある場合に発生するプログラムタイプの既に存在するエラー。依存関係グラフを確認するには、次を実行します

gradlew -q dependencies

または

gradle -q dependencies

(クラスパスにGradleが必要です)

繰り返しライブラリを整理し、繰り返しライブラリを削除すれば、エラーはなくなります。

5
Kiran Maniya

これら2つの依存関係の代わりに

implementation 'me.dm7.barcodescanner:zxing:1.9'
implementation 'com.journeyapps:zxing-Android-embedded:[email protected]'

これらの2行を追加します

implementation('me.dm7.barcodescanner:zxing:1.9'){
   exclude module: 'support-v4'
}

implementation ('com.journeyapps:zxing-Android-embedded:[email protected]'){
   exclude module: 'support-v4'
}

うまくいけば、これは動作します

1
harsh

Appcompatとデザインの同じバージョンを使用してこの問題を解決します

 implementation 'com.Android.support:appcompat-v7:28.0.0-alpha1'
 implementation 'com.Android.support:design:28.0.0-alpha1'

しかし今、私はこのエラーを受け取りました

0
Hassan Fayyaz