web-dev-qa-db-ja.com

AngularコンパイラのエラーにはTypeScript> = 3.1.1と<3.2.0が必要ですが、代わりに3.2.1が見つかりました

このエラーが出ます

AngularコンパイラのエラーにはTypeScript> = 3.1.1および<3.2.0が必要ですが、代わりに3.2.1が見つかりました。

TypeScriptが更新されたようですが、Angular Compilerはそれを好まない。

これをどのように修正しますか?

102
Matt

これを修正するには、特定のTypeScriptバージョン3.1.6をインストールしてください。

npm i [email protected] --save-dev --save-exact
144
Matt

私の場合、下記のコマンドはウィンドウズで動作しました。それは3.1.1と3.2.0の間の最新の必要なバージョンをインストールします。 OSに応じて、二重引用符または一重引用符を使用してください。

npm install [email protected]">=3.1.1 <3.2.0" 
96
J Sushil

対象となるバージョンを最初にインストールする

npm i [email protected] --save-dev --save-exact

それからコンパイルする前に

   npm i
13
npm install [email protected]">=3.1.1 <3.3.0" --save-dev --save-exact
rm -rf node_modules
npm install
6
Pala

CircleCiのエラーログから同様のエラーを得ました。

"AngularコンパイラのエラーにはTypeScript> = 3.1.1および<3.3.0が必要ですが、3.3.3333が代わりに見つかりました。"

これがAngularアプリケーションに影響を及ぼさなかったことをあなたは知っていますが、CircleCiエラーは厄介になっていました。 Angular 7.1を実行しています

$ npm i [email protected] --save-dev --save-exactでpackage-lock.jsonファイルを更新しました。

それから私は走った:$ npm私

その後私は走った:$ npm監査修正

「このCircleCiエラーメッセージ」は消えました。それでうまくいきます

3
Marvin Dawson