web-dev-qa-db-ja.com

2821ISRをアスタリスクPBX PRI行に設定するにはどうすればよいですか?

会社の電話システムをCiscoのCUCMからアスタリスクソリューションに移行しようとしています。

PBXinaflashサーバーをセットアップし、www.vitelity.comでアカウントをセットアップしました。私はそれを機能させることができました。通話を送受信でき、IVRに接続しました。

次に、現在のVOIPゲートウェイのバックアップとして、PRIカードを備えたCisco 2821ISRを購入しました。現在の構成をロードすることができ、PRIラインを接続した後、CiscoCUCMで動作しました。

その後、2821を再構成する方法をゴーグル検索しました。シスコのドキュメントをダウンロードして、Googleでいくつかの例を見つけました。最初に試した後、電話をかけることができました。 IVRを呼び出して、ダイヤルしていた数字を認識させることができました。他の電話の発信者IDは、正しい発信者IDを示していました。問題は、着信コールを機能させることでした。これまでのところ、カチッという音、ダイヤルトーン、すべての回線がビジーで、実際の電話が鳴らずに鳴るようになっています。

私の目的は、アスタリスクIVRに任意の電話番号のすべての通話をピックアップさせることです。 DIDは約150ありますが、実際に使用されるのは4つだけです。

私の質問は、誰かがこのタイプのセットアップを機能させているかということです。出来ますか?構成を教えていただけますか?

問題は、2821の構成またはアスタリスクのトランク構成のいずれかであると思います。

[Cisco 2821 ISR〜10.1.10.252]

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname asterisk
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
clock timezone GMT -6
network-clock-participate wic 1 
network-clock-select 1 T1 0/1/0
!
dot11 syslog
ip source-route
!
ip cef
!
no ipv6 cef
!
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
voice rtp send-recv
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 signaling forward unconditional
 fax protocol Cisco 
 sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
!
voice-card 0
 dspfarm
!
archive
 log config
  hidekeys
!
controller T1 0/1/0
 pri-group timeslots 1-24
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.1.10.252 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn calling-number 3167945555
 isdn supp-service name calling
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.10.253
no ip http server
no ip http secure-server
!
control-plane
!
voice-port 0/1/0:23
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
no mgcp explicit hookstate
!
dial-peer voice 1 pots
 numbering-type unknown
 destination-pattern .
 direct-inward-dial
 port 0/1/0:23
 forward-digits all
!
dial-peer voice 2 voip
 numbering-type unknown
 destination-pattern .
 session protocol sipv2
 session target ipv4:10.1.10.7:5060
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
!
gateway 
 timer receive-rtp 1200
!
sip-ua 
 retry invite 3
 retry response 3
 retry bye 3
 retry cancel 3
 timers trying 1000
 sip-server ipv4:10.1.10.7
!
line con 0
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 login
 transport input telnet
line vty 5 15
 login
 transport input telnet
!
scheduler allocate 20000 1000
end

[アスタリスクトランク〜10.1.10.7]

Outgoing Settings

Trunk Name:
Cisco2821

PEER Details:
type=friend
qualify=yes
nat=no
insecure=very
Host=10.1.10.252
dtmfmode=rfc2833
disallow=all
context=from-internal
allow=ulaw&alaw

Incoming Settings

USER Context:
from-internal

USER Details:
type=friend
qualify=yes
nat=no
Host=10.1.10.252
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw&alaw
1
Sam Sanders

OK、動作しました。2821ISRでデバッグログを使用する方法を学ぶ必要がありました。このプロジェクトに協力してくれたfreepbx.orgのSkykingOHに感謝します。

debug isdn q931
debug voip dialpeer inout
debug voip dialpeer detail
debug ccsip states
debug ccsip info
debug ccsip calls
debug ccsip events
debug ccsip messages

[アスタリスクトランク〜10.1.10.7]も簡略化しました

PEER Details:

type=friend
qualify=yes
nat=no
insecure=port,invite
Host=10.1.10.252
dtmfmode=rfc2833
disallow=all
context=from-trunk
allow=ulaw

2821の構成

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname asterisk
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password ********
!
no aaa new-model
clock timezone GMT -6
network-clock-participate wic 1 
network-clock-select 1 T1 0/1/0
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name *********.com
ip name-server 10.0.0.21
ip name-server 10.0.0.22
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
voice rtp send-recv
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 signaling forward unconditional
 fax protocol Cisco 
 sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
!
voice-card 0
 dspfarm
!
archive
 log config
  hidekeys
!
controller T1 0/1/0
 pri-group timeslots 1-24
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.1.10.252 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn calling-number 316********
 isdn supp-service name calling
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.10.253
no ip http server
no ip http secure-server
!
!
ip dns server
!
logging trap warnings
logging 10.0.0.14
!
control-plane
!
voice-port 0/1/0:23
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
no mgcp explicit hookstate
!
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
 port 0/1/0:23
 forward-digits all
!
dial-peer voice 2 voip
 destination-pattern ^[2-9]......$
 session protocol sipv2
 session target ipv4:10.1.10.7:5060
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 9001 pots
 preference 1
 destination-pattern .
 port 0/1/0:23
 forward-digits all
!
!
gateway 
 timer receive-rtp 1200
!
sip-ua 
 no remote-party-id
 retry invite 3
 retry response 3
 retry bye 3
 retry cancel 3
 timers trying 1000
 sip-server ipv4:10.1.10.7
!
!
!
line con 0
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 login
 transport input telnet
line vty 5 15
 login
 transport input telnet
!
scheduler allocate 20000 1000
end

デバッグを使用した後、電話会社(COX)がトランク番号に7桁の数字を送信していることを知りました。

0
Sam Sanders