web-dev-qa-db-ja.com

cisco ip nat /ポートフォワーディング

新しくインストールしたCiscoルーターでポートフォワーディングを機能させようとしています。私は自分のせいがどこにあるのかわからないようで、かなり長い間探していました。

私の設定の関連セクション:

interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 speed 100
 full-duplex
 no cdp enable
!
interface FastEthernet0/1
 ip address 10.10.250.1 255.255.255.0
 ip nat inside
 speed 100
 full-duplex
!
router eigrp 250
 passive-interface FastEthernet0/0
 network 10.10.250.0 0.0.0.255
 no auto-summary
!
ip nat inside source list NAT interface FastEthernet0/0 overload
ip nat inside source static udp 10.10.250.201 9987 interface FastEthernet0/0 9987
ip nat inside source static tcp 10.10.250.201 30033 interface FastEthernet0/0 30033
ip nat inside source static tcp 10.10.250.201 10011 interface FastEthernet0/0 10011
ip nat inside source static tcp 10.10.250.201 22 interface FastEthernet0/0 443
ip nat inside source static tcp 10.10.250.201 80 interface FastEthernet0/0 80
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp
!
!
!
ip access-list extended NAT
 permit ip any any

どこかで私の設定に問題があるはずですか?または、ポートフォワーディングを機能させるために必要なものが不足していますか?

これが現在のNATテーブルを削除して私のルールのみを表示しています:

Cisco2621#show ip nat tran
Pro Inside global         Inside local          Outside local         Outside global
udp x.x.x.x:9987    10.10.250.201:9987    ---                   ---
tcp x.x.x.x:10011   10.10.250.201:10011   ---                   ---
tcp x.x.x.x:80      10.10.250.201:80      ---                   ---
tcp x.x.x.x:443     10.10.250.201:22      ---                   ---
tcp x.x.x.x:30033   10.10.250.201:30033   ---                   ---
3
h3rrmiller

ポートフォワーディングで送信元と宛先を混同しました。

ip nat inside source static udp  interface FastEthernet0/0 9987 10.10.250.201 9987 extendable
ip nat inside source static tcp  interface FastEthernet0/0 30033 10.10.250.201 30033 extendable
ip nat inside source static tcp  interface FastEthernet0/0 10011 10.10.250.201 10011 extendable
ip nat inside source static tcp  interface FastEthernet0/0 443 10.10.250.201 22 extendable
ip nat inside source static tcp  interface FastEthernet0/0 80 10.10.250.201 80 extendable

また、標準のアクセスリストを使用して、ローカルネットワークのみがNATを通過できるようにします。

ip access-list standard NAT
 permit ip 10.10.250.0 0.0.0.255
1
Mikhail Khirgiy

NATを実行してから久しぶりですが、「ip nat inside ...」の行で、最後にインターフェイスを配置できますか?インターフェイスの適切なIPアドレスである必要があると思いました。ただし、構成では、DHCPが原因で機能する場合があります。

次のコマンドを試して、問題を絞り込んでください。

show ip nat translations
debug ip nat (then try to generate traffic that should hit the NAT and see what hits the console)
show ip nat stat

また、この時点では何もフィルタリングしていないため、拡張アクセスリストを使用しないようにしてください。違いはないはずですが、3秒で試す価値があります。

access-list 10 permit any
0
Fr3nzy