web-dev-qa-db-ja.com

apt-getはdebian7のopensslをアップグレードしません

私は次の問題に直面しています。コマンドを実行するとSudo apt-get upgrade、私は得る:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  libssl1.0.0:i386
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

そして私が実行した場合Sudo apt-get install libssl1.0.0:i386

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 Apache2-mpm-prefork : Depends: Apache2.2-bin (= 2.2.22-13+deb7u1) but it is not going to be installed
 Apache2.2-common : Depends: Apache2.2-bin (= 2.2.22-13+deb7u1) but it is not going to be installed
                Depends: Apache2-utils but it is not going to be installed
                Recommends: ssl-cert but it is not going to be installed
 libssl1.0.0 : Breaks: libssl1.0.0:i386 (!= 1.0.1e-2+deb7u6) but 1.0.1e 2+deb7u7 is to be installed
 libssl1.0.0:i386 : Breaks: libssl1.0.0 (!= 1.0.1e-2+deb7u7) but 1.0.1e-2+deb7u6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

私はDebian764を使用しています。

実際に何が起こっているのか説明していただけますか?私のサーバーに何か問題がありますか?

ありがとうございました。

問題は、AMD64i386の両方のバージョンのlibssl1.0.0を一緒にインストールできないことであるようですただしまったく同じバージョンである場合を除きます。 AMD64バージョンの上は1.0.1e-2+deb7u6であり、i386バージョンは1.0.1e-2+deb7u7です。

何らかの理由で、i386アーキテクチャには他のアーキテクチャよりも新しいバージョンのパッケージがありますが、これがなぜであるかは不明です。おそらく、サーバーを介して伝播するのに時間がかかっているだけです。パッケージは重要なセキュリティアップデートのようです。以下の変更をコピーしました。

openssl(1.0.1e-2 + deb7u7)wheezy-security;緊急度=高

  • セキュリティチームによるメンテナ以外のアップロード。
    • CVE-2010-5298を修正:解放後使用の競合状態。
    • Opensslからlibssl1.0.0へのバージョン管理された依存関係を、CVE-2014-0160(クローズ:#744194)の修正があるバージョンに追加します。
    • アップグレード時に韻律を再開することを提案します(クローズ:#744871)。
    • Apache2のインストールを正しく検出し、再起動することを提案します(クローズ:#744141)。
    • 再起動をチェックするサービスをさらに追加します。
    • TSA拡張キー使用のクリティカルフラグが常に検出されるとは限らないバグと、他の2つの同様のケースを修正します。
    • 'libraries/restart-without-asking'のサポートを追加します。これにより、プロンプトを表示したり、代わりに応答を要求したりせずに、サービスを自動的に再起動できます。
    • CVE-2014-0076を修正:「Yarom/BengerFLUSH + RELOADキャッシュサイドチャネル攻撃」(クローズ:#742923)。

--Raphael Geissert Thu、2014年4月17日22:11:33 +0200

おそらく最善の方法は、パッケージがAMD64で使用可能になるまで待つことです。 i386はとにかくサーバーの外部アーキテクチャであるため、AMD64バージョンが主に使用されるため、とにかくインストールしてもセキュリティ上の利点はない可能性があります。おそらく、i386は、常に何も実行されていない周辺機器パッケージの依存関係にすぎません(ただし、すべての依存関係を確認する必要があります)。

2
Graeme