web-dev-qa-db-ja.com

EclipseでTomcat 8を使用する方法は?

EDIT 2014-02-07:Eclipse Lunaがここにあり、Tomcat 8のサポートがバンドルされたWTPに含まれています:)Happy days!

Tomcat 8はまだ開発中ですが、入手できます こちら 。現在、Apache TomcatのメインページにRCバージョンがあります。アップデート2/27/14:8がリリースされ、アダプターはWTP用に構築されましたが、まだEclipseバンドルに統合されていません。すぐに!

ただし、Eclipse Keplerでは、Tomcat 8のサーバー追加リストにサポートされているアダプターはありません。Tomcat7アダプターは機能せず、「新しい拡張機能のインストール」でダウンロードする新しい拡張機能がないようです。ダイアログ。

Eclipseの外部でローカルに実行し(Tomcat 8)、コードをステップ実行するためにリモートデバッガをフックする唯一のオプションはありますか? Eclipse Kepler + Tomcat 8でも機能しますか? IntelliJ IDEA 12は、私がその道に入れた30分以内にそれを行うことができませんでした。

なぜ私がこれをやろうとしているのか疑問に思っているなら、Spring 4.0.0.M1と4.0.0.M2のWebSocketを使って遊んでいる。彼らは(Rossen StoyanchevのSpring 4.0 ブログ投稿 および例による)JSR-356を使用します。これは理論的にはTomcat 7にバックポートされるようにTomcat 8に実装されています。

「Spring 4 WebSocketサポートのために開発環境を簡単に手に入れるにはどうすればよいですか?」というより広範な質問への回答。 Niceになりますが、サポートされていないWebサーバーをEclipseにプラグインする方法を知ることもできます。

乾杯、E

** 2013年8月7日更新-Rossen StoyanchevはSpring 4.0.0.M2 blog を更新し、jpdaの知恵を追加して、リモートデバッグを使用していることを共有しました。

そうは言っても、Eclipse内でTomcat 8を使用してデバッグするのはそれほど難しくありません。 bin/startup.shの最後の行を次のように変更するだけです(「jpda」が追加されていることに注意してください)。

 exec "$PRGDIR"/"$EXECUTABLE" jpda start "[email protected]"

Eclipse内で、localhostポート80のリモートデバッグ構成を作成し、Tomcatの起動後に起動します。ソースコードにブレークポイントを配置できます。

ロッセンありがとう!

**アップデート9/29/13-Eclipse Kepler SR1が到着しましたが、残念です! Tomcat 8のWTPサポートはありません。Tomcat8はRC3までです。

** 13/12/5更新

  • ブログのURLの修正。
  • Tomcat 8からRC5まで。
  • Tomcat 8をサポートするためにEclipseでWTP修正を追跡するバグ HERE
  • IntelliJ IDEA新しいバージョン13は、Tomcat 8をサポートするようになったと言っています。まだ個人的には試していません。
50
ECDragon

UPDATE:Eclipse Mars EE以降では、Tomcat8がネイティブでサポートされています。これは、Eclipseの以前のバージョンがある場合にのみ使用してください。


Eclipseの最新バージョンはまだTomcat 8をサポートしていませんが、WTPの新しいバージョンを追加でき、Tomcat 8のサポートはネイティブに追加されます。これをする:

  • Java EE のEclipseの最新バージョンをダウンロードします
  • WTPダウンロードページ に移動し、最新バージョン(現在3.6)を選択して、Zipをダウンロードします(Traditional Zip Files ... Web App Developersの下)。 これが現在のリンクです
  • ダウンロードしたWTPの機能およびプラグインディレクトリ内のすべてのファイルを、Eclipseフォルダー内の対応するEclipseディレクトリーにコピーします(既存のファイルを上書きします)。

Eclipseを起動すると、デプロイするときにTomcat 8オプションが使用可能になります。 enter image description here

59
Jason

私はジェイソンの手順に従いますが、うまくいきません。

そして、WTP更新サイト http://download.Eclipse.org/webtools/updates/ を見つけました。

Help -> Install new software -> Add > WTP:http://download.Eclipse.org/webtools/updates/ -> OK

それからHelp -> Check for update、ちょうど動作します、私はジェイソンがこれに影響するかどうかわかりません。

14
wener

Eclipseプラグインがチェックしているのは、内部のTomcatバージョンのみです。

catalina.jar!/org/Apache/catalina/util/ServerInfo.properties

プロパティファイルをTomcat7のファイルに置き換え、Eclipseの問題を修正しました

Spring-websocketsサンプルアプリをデプロイできるようにするには、Eclipseで次のファイルを編集する必要があります。

.settings/org.Eclipse.wst.common.project.facet.core.xml

Webバージョンを2.5に変更します

<installed facet="jst.web" version="2.5"/>
13
Javier Sabino

これは受け入れられた答えの下のコメントであるはずですが、私はまだ50の評判を持っていません。

http://download.Eclipse.org/webtools/downloads/

最初にリリースされた3.5.2を選択しました。次に、Integration 3.6.0を選択し、Dynamic Web ProjectのNew ProjectのTomcat 8を見ました。

7
Wildly Stunted

私は以下を試してみましたが、うまくいきました。

  1. Eclipseで[ヘルプ]-> [Eclipse Marketplace]に移動します
  2. 検索ボックスにJST拡張機能を入力します。
  3. Luna用のJSPアダプターのインストール
  4. Eclispeを再起動します
  5. 新しいサーバーを追加するときに、Tocmat 8サーバーが表示されるはずです。
5
manali

Tomcat 9.0(トランクからのTomcatビルド)をEclipseのサーバーとして追加します。

ServerInfo.propertiesファイルのプロパティを以下のように更新します。

server.info=Apache Tomcat/@[email protected]
[email protected][email protected]
[email protected][email protected]


server.info=Apache Tomcat/7.0.57
server.number=7.0.57.0
server.built=Nov 3 2014 08:39:16 UTC

トランクからTomcatサーバーを構築し、EclipseでTomcat7インスタンスとしてサーバーを追加します。

ServerInfo.propertiesファイルの場所:\ Tomcat\Java\org\Apache\catalina\util\ServerInfo.properties

@Jasonの答えに加えて、アプリを実行するにはもう少しやらなければなりませんでした。

  • ダウンロードして解凍 Eclipse IDE for Java EE DevelopersEEエディション)
  • Eclipseの Web Tools PlatformStable(Milestone)3.6 + をダウンロードして解凍します
  • Eclipse IDEの2つのフォルダーをWTPフォルダー(機能とプラグインフォルダー)で上書きします。
  • ダウンロードして解凍 Tomcat 8
  • Eclipseでは、新規->その他->サーバー-> Tomcat 8(解凍された場所を選択)
  • 404を取得した場合、サーバービューでTomcat 8をクリックします->サーバーの場所->Tomcatインストールを使用に変更し、Deploy path:to webapps*(これを編集できない場合は、 公開されているwebappを削除します
2
lko

Springsource STS(3.6)の最新バージョンはTomcat 8をサポートしています。これはEclipse Luna 4.4に基づいており、Java 8をサポートしています。

0
TechTrip

http://download.Eclipse.org/webtools/repository/luna を使用してEclipse Lunaをダウンロードし、WTPをインストールしました

Tomcat 8をダウンロードし、Eclipseで新しいサーバーを構成しました。 Eclipse lunaでTomcat 8をセットアップできるようになりました

0

独自のバージョンのTomcat v8をrootユーザーを使用してカスタムディレクトリ(linux)に展開した場合、TOMCATROOT/libディレクトリのデフォルトの権限では通常のユーザーアクセスが許可されません。

Eclipseは、catalina.jarを確認してバージョンを確認することはできません。したがって、server.propertiesをいじり回すことは役に立ちません。

chmod u + x lib /を追加して、通常のユーザーがライブラリにアクセスできるようにします。

0
Callum Wilson

あるいは、Eclipse更新サイトを使用することもできます([ヘルプ]-> [新しい機能のインストール]-> [サイトの追加](以下のURL)->必要な機能の選択)。

Lunaの場合: http://download.Eclipse.org/webtools/repository/luna

ケプラーの場合: http://download.Eclipse.org/webtools/repository/kepler

Heliosの場合: http://download.Eclipse.org/webtools/repository/helios

古いバージョンの場合: http://download.Eclipse.org/webtools/updates/

0
Yogendra Singh