web-dev-qa-db-ja.com

Force Android Studioはgradle 1.10または1.1をダウンロードしてインストールします

Android Studio 0.5.1をインストールしましたが、プロジェクトが動作しなくなりました。エラーは次のとおりです。

The project is using an unsupported version of Gradle. Please use version 1.10.

私はgradle-wrapper.propertiesおよびgradle.buildファイルの設定を変更しようとしましたが、運はありませんでした。

gradle-wrapper.propertiesファイル:

#Wed Mar 12 11:11:46 CET 2014
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.Zip

私のgradle.buildは次のようになります:

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:0.9.+'

    }
}
apply plugin: 'Android'

repositories {
    mavenCentral()
}

dependencies {
    compile fileTree(dir: 'libs', include: '*.jar')
    compile 'de.timroes.Android:EnhancedListView:[email protected]'
}

Android {
    compileSdkVersion 19
    buildToolsVersion "19.0.0"

    sourceSets {
        main {
            manifest.srcFile 'AndroidManifest.xml'
            Java.srcDirs = ['src']
            resources.srcDirs = ['src']
            aidl.srcDirs = ['src']
            renderscript.srcDirs = ['src']
            res.srcDirs = ['res']
            assets.srcDirs = ['assets']
        }


        instrumentTest.setRoot('tests')

        debug.setRoot('build-types/debug')
        release.setRoot('build-types/release')
    }
}

どうすればAndroid Studioにgradle 1.10または1.11をダウンロードさせることができますか?

ありがとう!

22
Draško

これを試して:

Gradle-wrapper.propertiesを変更します

distributionUrl=http\://services.gradle.org/distributions/gradle-1.11-all.Zip

あなたのbuild.gradle

compileSdkVersion 19 
buildToolsVersion "19.0.1"

ランニング:./gradlew clean assembleターミナルで

また、 this を読むこともできます。

gL HF

更新、彼はそれを解決しました:

https://plus.google.com/101589574290830309525/posts/7YzcE6YpfwK

.ideaフォルダーとすべての.imlファイルを削除し、プロジェクトを新しいものとしてインポートすることで、ようやく解決しました。

27
douglaszuniga

Githubからgradleプロジェクトをインポートしようとしたときにこの問題が発生しました。プロジェクトにはgradleラッパーはありませんでした。新しいAndroidプロジェクトをAndroid studioで作成し、gradleフォルダをgithubから取得したプロジェクトにコピーしました。その後、gradleセクションのプロジェクトの設定で、私は「デフォルトのグラドルラッパーを使用する」を選択しました。それで問題は解決しました。

3
Murat

BuildToolsVersionを19.0.3に変更して、SDKマネージャーにインストールすることを忘れないでください

2
curioushikhov

サブプロジェクトがあった以前のコミットに同期したため、このエラーが発生し始めました

    classpath 'com.Android.tools.build:gradle:0.7.+'

build.gradleで。これを0.9。+に変更すると、エラーが修正されました。

1

Webサイトから目的のバージョンのgradleをダウンロードすることで、同じ問題を解決できました。 http://www.gradle.org/downloads

次に、Zipファイルを抽出し、iibフォルダーをAndroid studio gradle lib。

たとえば、次のとおりです。

Downloads/gradle-1.10/lib /を/ Applications/Android Studio.app/plugins/gradle/lib/にコピーします

次に、Android studioをリロードすると、動作するはずです。

1
Reedy

Gradleの最新バージョン1.11を使用することをお勧めします。 Androidツールチームは、古いGradleバージョンのサポートを終了します(これは私が行うことです)。

ラッパーを1.10から1.11に変更したら、Gradle設定でラッパーが有効になっていることを確認する必要があります。

その後、プロジェクトを同期することを忘れないでください!

enter image description here

0
vRallev

gradleラッパーファイルとgradleプロパティファイルを削除し、プロジェクトをリロードするだけで、自動更新により残りが作成されます

0
parrita