web-dev-qa-db-ja.com

オペレーティングシステムまたはアーキテクチャとの互換性がない:[email protected]

Ubuntu 15.04を使用しています。次のコマンドを実行中:

npm install fsevents

私は次のエラーが発生しています:

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: [email protected]
npm WARN [email protected] No repository field.

誰かがこれを解決しましたか?

63
randomuser

他のアプリケーションを構築するときに、この依存関係で同じ問題に直面していました。

知識のためと、NPMにあまり慣れていない人々のために、したがって、アプリケーションの動作について不確実です。

fseventsOS XのAPIにより、アプリケーションが特定のディレクトリツリーへの変更の通知を登録できるようにするためです。ランニング:

npm install --no-optional

欠点なしでトリックを行います。

95
Cezar Augusto

これはエラーではなく、単なる警告です。オプションの依存関係です。

8
JMM

以下のコマンドラインを使用して、デフォルトでオプションの依存関係をインストールしないようにnpmに指示できます。

npm config set optional false
3
Simon D

ERRが発生している場合!この問題の原因として考えられるのは、実際には古いバージョンのNPMを使用していることです。

私にとって、私はいくつかのサーバーにシェルし、「なぜこれが機能しないのですか?」のように、このエラーを取得しました:

npm ERR! Linux 4.4.0-130-generic
npm ERR! argv "/home/william/.nvm/versions/node/v4.4.3/bin/node" "/home/william/.nvm/versions/node/v4.4.3/bin/npm" "install"
npm ERR! node v4.4.3
npm ERR! npm  v2.15.1
npm ERR! code EBADPLATFORM

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: [email protected]
npm ERR! notsup Valid OS:    darwin
npm ERR! notsup Valid Arch:  any
npm ERR! notsup Actual OS:   linux
npm ERR! notsup Actual Arch: x64

npm ERR! Please include the following file with any support request:
npm ERR!     /home/william/app/mcard-api/npm-debug.log

このサーバー(私が最近買収したばかり)がnpm 2.15.1を実行していたことが判明しました。 nvmを再インストールし、nvm install --ltsで修正しました。

2
csga5000

Redux のインストール時にもこのエラーに直面していました。

$ npm install --save react-redux
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: [email protected]

問題を解決したのは、 --no-optional を追加することでした(引数により、オプションの依存関係がインストールされないようにします):

npm install --no-optional --save react-redux
            ^^^^^^^^^^^^^

そして今、それは正しくインストールされています:

$ npm ls redux
[email protected] /home/me/projects/reduxproject
└── [email protected] 
0
fedorqui

依存関係にも同じ問題がありました。 package.jsonファイルを確認し、devDependencyセクションに「typings」:「^ 0.8.1」エントリを追加します。前にコンマを追加することを忘れないでください:)それが問題を解決することを願っています。

0
santosh bhoyar

「yarn add」を使用すると見つかりました。ヤーンは、fseventsがエラーをスローしないことを除外します。

0
Supa_dave72