web-dev-qa-db-ja.com

Yarnでパッケージをインストールする場合、「不適切なピアの依存関係」とはどういう意味ですか?

クローンを作成しました a repo 。依存関係をインストールするには Yarn を使用することをお勧めします。 yarn installを実行すると問題ないようですが、次の警告が表示されます。

yarn install v0.20.3
[1/4] ????  Resolving packages...
[2/4] ????  Fetching packages...
[3/4] ????  Linking dependencies...
warning "[email protected]" has incorrect peer dependency "[email protected]^3.4.2".
[4/4] ????  Building fresh packages...
✨  Done in 77.59s.

「ピアの依存関係が正しくない」とはどういう意味かをオンラインで調べました。しかし、私が見つけることができるのは、他のリポジトリで報告された問題、または問題の修正方法に関する質問です。

誰かがこれが何を意味するのか、なぜそれが警告ではなくエラーではないのかを説明できますか?

また、複製したばかりのレポの背後にあるコミュニティに対処したり、報告したりする必要がありますか?

43
shrewdbeans

これは、コードの実行を実際に停止することはないため、警告にすぎません。依存関係に問題があることを示すためにあります。

事実上、ピアの依存関係は、パッケージが「私を使用するには、yパッケージのxバージョンもインストールする必要があります」と指定する方法です。

最新バージョンにアップグレードする必要があります。sass-loaderの依存関係の詳細については、この link を参照してください。

14
JonnyFoley