web-dev-qa-db-ja.com

libssl0.9.8をdebian7にインストールする

Debian 7にuTorrentをインストールしようとしていますが、実行しようとするたびに次のエラーメッセージが表示されます。

error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

Debianリポジトリではもう利用できないと思います。問題を解決するためにシンボリックリンクを作成しようとしましたが、同じメッセージが表示されます。どうすればこの問題を解決できますか?

7
hamedkh

AMD64用のパッケージがあります

http://snapshot.debian.org/archive/debian/20110406T213352Z/pool/main/o/openssl098/libssl0.9.8_0.9.8o-7_AMD64.deb

そしてそれをインストールします:

[email protected]:/etc/php5/fpm/conf.d# dpkg -i libssl0.9.8_0.9.8o-7_AMD64.deb
Selecting previously unselected package libssl0.9.8.
(Reading database ... 120511 files and directories currently installed.)
Unpacking libssl0.9.8 (from libssl0.9.8_0.9.8o-7_AMD64.deb) ...
Setting up libssl0.9.8 (0.9.8o-7) ...

[email protected]:/etc/php5/fpm/conf.d# php -v
PHP 5.4.4-14+deb7u2 (cli) (built: Jun  5 2013 07:56:44)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
    with Xdebug v2.2.1, Copyright (c) 2002-2012, by Derick Rethans
    with Zend Debugger v5.3, Copyright (c) 1999-2010, by Zend Technologies
[email protected]:/etc/php5/fpm/conf.d#
14
Vail

Debian 7ではlibssl1.0.0しか見つかりませんが、libssl0.9.8はdebian 6(スクイーズ)の一部です。 here からパケットを取得し、次のようなコマンドを使用して手動でインストールできます。

dpkg -i libssl0.9.8_0.9.8o-4squeeze14_i386.deb

64ビットアーキテクチャの場合、uTorrentバイナリは実際には32ビットでのみ使用できるため、インストールする前に32ビットのlibcおよびzlib1gバイナリが必要です。それらを追加するには、i386アーキテクチャdpkg --add-architecture i386を追加し、[Arch = AMD64、i386]を/etc/apt/sources.listのリポジトリに追加する必要があります。詳細については、 http://wiki.debian.org/Multiarch/HOWTO を参照してください。次に、apt-get update; apt-get install libc6:i386 zlib1g:i386を実行する必要があります

4
George Ciobanu

最近、gitlabで同じ問題が発生しました。 libssl.so.0.9.8を取得してみてください。

wget http://snapshot.debian.org/archive/debian/20110406T213352Z/pool/main/o/openssl098/libssl0.9.8_0.9.8o-7_i386.deb

そしてそれをインストールするには:

Sudo dpkg -i libssl0.9.8_0.9.8o-7_i386.deb
0
Vasil Dakov

Ubuntu 12.04でも同じ問題が発生しましたが、これをインストールすると修正されました。

Sudo apt-get install ia32-libs
0
ShazbotTKC