web-dev-qa-db-ja.com

Mac OS Xでデフォルトの画面共有/ VNCポート番号を変更するにはどうすればよいですか?

デフォルトから変更する方法はありますか5900他のポートへ?

10
GJ.

実際には、Mac OS 10.7 Lionおよび10.8 Mountain LionでAppleのVNCサーバーのデフォルトポートを切り替えることができます。ポートを変更するには、サーバーのplistファイル/System/Library/LaunchDaemons/com.Apple.screensharing.plistを編集する必要があります(このファイルは、10.7 Lionより前のシステムには存在しません)。

ファイルを編集するには、root(Sudo)特権が必要です。ターミナルで、viまたは vim に慣れている場合は、次のように入力できます。

Sudo vim /System/Library/LaunchDaemons/com.Apple.screensharing.plist

または、そうでない場合は nano を使用することをお勧めします。

Sudo nano /System/Library/LaunchDaemons/com.Apple.screensharing.plist

これで、行34(<string>vnc-server</string>を読み取る行)を<string>nnnn</string>に変更するだけです。ここで、nnnnは、使用するポート番号です。 「vnc-server」のような名前を数字に変更するのは奇妙に思えますが、それはあなたがそれをしなければならない方法です。不明な点がある場合のために、以下に例を示します。

デフォルトのポートを54321に変更するには、plistファイルを次のように編集します。

...
<key>Sockets</key>
  <dict>
      <key>Listener</key>
      <dict>
          <key>Bonjour</key>
          <string>rfb</string>
          <key>SockServiceName</key>
          <string>54321</string>            <!-- Change this line! -->
      </dict>
  </dict>
  <key>UserName</key>
  <string>root</string>
  <key>SHAuthorizationRight</key>
  <string>system.preferences</string>
</dict>
</plist>

ファイルを保存した後、変更を有効にするには、[共有]設定ペインで[画面の共有]をオフにしてからもう一度オンにするか、次のコマンドを使用してサービスをアンロードして再ロードします。

Sudo launchctl unload /System/Library/LaunchDaemons/com.Apple.screensharing.plist
Sudo launchctl load /System/Library/LaunchDaemons/com.Apple.screensharing.plist
16
Greg Canty

Google経由でこのスレッドを見つけた後、編集していることを確認できます/etc/services "rfb"ポートは、含まれているVNCサーバーのリスニングポートを変更します。

ファイルを編集して再起動しました(通常、サービスを再起動するか、launchdeamonをアンロードしようとしましたが、他にもいくつか問題があり、気にしませんでした)。 iPadのiTeleportは5900に接続できず、選択した非特権ポートで成功しました。

5
MichaelM

これは Apple.com のさまざまなフォーラムと macosxhints.com で議論されています。簡単に言えば、「変更することはできません」です。

より長い回答はそれを回避する方法を示唆しています-3つの可能性:

  • 別のVNCサーバーソフトウェアを使用する
  • Sshトンネルを使用してカスタムポートから5900にトラフィックをリダイレクトする
  • ルーターのポートマッピングを構成して、別のポートの着信トラフィックをMacのポート5900に移動します。
3
Doug Harris

このスレッドでGregが提供した情報に基づいて、システムのVNCリスニングポートを変更するプロセスを自動化するbashスクリプトを作成しました。私のテストではうまく機能します。誰か問題があれば教えてください。

#!/bin/sh

#Created by Will D. on 04/10/2015
#If you find it useful (or have suggestions, feedback, etc.), shoot me an email at [email protected].
#Requires Mac OS 10.7.x or later (tested up to and including 10.10.3)
#02/02/2016 - Updated Script to alert for SIP status

#Setting Static Variables
sourcepath="/System/Library/LaunchDaemons/"
filename="com.Apple.screensharing.plist"
port=`less $sourcepath$filename | awk 'f{print $1;f=0} /SockServiceName/ {f=1}' | awk -F "<|>" '{print $3}'`
os_version=`sw_vers -productVersion`
os_version_aug=`sw_vers -productVersion | awk -F "." '{print $1$2}'`
sip_status=`csrutil status | awk '{print $5}'`
#Colors
nc='\033[0m'
light_red='\033[1;31m' #Light Red
yellow='\033[1;33m' #Yellow

clear

#Check the script is being run by root
if [ "$EUID" -ne 0 ];then
    printf "${light_red}This Script Must Run As Root${nc}\n"
    exit 0
fi

clear
printf ${yellow};echo "---------------------------------------------------------------"
echo "---                                                         ---"
echo "--- This Script Will Change Your Systems VNC Listening Port ---"
echo "---             Hit Ctrl + c to exit at anytime             ---"
echo "---                                                         ---"
echo "---------------------------------------------------------------";printf "${nc}\n"

#Check System Version
sleep 1
if [ "${os_version_aug}" -lt "107" ]; then
echo ""
echo "System OS Must Be Greater Than 10.7.x.  Aborting Script."
exit 0
else
echo ""
echo "System OS Version is" $os_version
echo "OS Requirement Met √"
echo "--------"
fi

if [ "${os_version_aug}" == "1011" ]; then
    if [ "${sip_status}" == "enabled." ]; then
        echo ""
        printf "${light_red}••• System Integrity Protection is Enabled •••${nc}\n"
        echo ""
        echo "This script modifies /System/Library/LaunchDaemons/com.Apple.screensharing.plist"
        echo "Please Disable System Integrity Protection Before Running"
        echo ""
        exit 0
    fi
fi

#Give Feedback on Current Port
sleep 1
if [ "${port}" == "vnc-server" ]; then
echo ""
echo "The System's VNC Port is Currently"
echo "Set to the System Default Port of 5900."
echo "--------"
Elif [ "${port}" != "vnc-server" ]; then
echo ""
echo "The System's VNC Port is Currently"
echo "Set to a Non-default Port of" $port"."
echo "--------"
fi

#Updating Port
echo ""
printf "What Port Would You Like VNC to Listen On? "
read newport
echo ""
echo "The Following Action Requires an Admin Password."
echo "Note: Your Password Will Be Visible When You Type It"
echo ""
printf "Admin Password? "
read admin_pass
sleep 1
echo ""
echo "Created" $filename".bak."
sleep 1
echo ""
echo "Updating VNC Port to" $newport"..."
echo $admin_pass | Sudo -S sed -i.bak -e "s|$port|$newport|g" $sourcepath$filename
sleep 1
echo "Done"
echo ""
sleep 1

#Restarting screensharing process
echo "Restarting Screen Sharing Service..."
Sudo launchctl unload /System/Library/LaunchDaemons/com.Apple.screensharing.plist
Sudo launchctl load /System/Library/LaunchDaemons/com.Apple.screensharing.plist
echo "Done"
sleep 1
echo ""
echo "Your System's VNC Port is Now Set to" $newport"."
echo ""
echo "Update Complete.  All Done."

if [ "${os_version_aug}" == "1011" ]; then
    echo ""
    echo "Since you're running El Capitan"
    echo "be sure to re-enable System Integrity Protection"
    exit 0
fi

exit 0
1
Will

System Integrity Protection を無効にせずにデフォルトのポートやバインディングアドレスを変更するには、/Libraryに新しいLaunchDaemonを作成する必要があります。

残念ながら、別のラベルを割り当てた場合、画面共有エージェントは正しく機能しません。つまり、デーモンは同じ名前を使用してオリジナルを「シャドウイング」する必要があります。再起動すると、システムが/Systemのオリジナルをロードし、/Libraryの変更されたバージョンを無視するため、これはそれ自体に問題があります。

解決策は、LaunchDaemonを無効にし、変更されたLaunchDaemonを強制的にロードする「ランチャー」デーモンを使用することです。ただし、設定が画面共有をアクティブ化するように注意する必要があります。そうしないと、最終的に 監視モードのみ になります。

一歩一歩

  1. システム環境設定で画面共有を有効にする
  2. Execute

    Sudo launchctl unload -w /System/Library/LaunchDaemons/com.Apple.screensharing.plist
    
  3. Execute

    Sudo cp /System/Library/LaunchDaemons/com.Apple.screensharing.plist /Library/LaunchDaemons/com.Apple.screensharing.plist
    
  4. /Library/LaunchDaemons/com.Apple.screensharing.plistで、[ソケット]セクションを編集して、目的の方法を確認します。たとえば、localhost:5901をリッスンします:

    <key>Sockets</key>
      <dict>
        <key>Listener</key>
        <dict>
          <key>SockNodeName</key>
          <string>localhost</string>
          <key>SockServiceName</key>
          <string>5901</string>
        </dict>
    </dict>
    
  5. 次の内容の/Library/LaunchDaemons/com.Apple.screensharing.launcher.plistを作成します。

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.Apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
      <key>Label</key>
      <string>com.Apple.screensharing.launcher</string>
      <key>LaunchOnlyOnce</key>
      <true/>
      <key>RunAtLoad</key>
      <true/>
      <key>KeepAlive</key>
      <false/>
      <key>ProgramArguments</key>
      <array>
        <string>/bin/launchctl</string>
        <string>load</string>
        <string>-F</string>
        <string>/Library/LaunchDaemons/com.Apple.screensharing.plist</string>
      </array>
    </dict>
    </plist>
    
  6. Execute

    Sudo launchctl load -w /Library/LaunchDaemons/com.Apple.screensharing.launcher.plist
    

この後、画面共有権限が適切にプロビジョニングされ、デフォルトのデーモンが自動的に読み込まれなくなり、ランチャーがカスタマイズされたデーモンを強制的に起動します。

0
Mathieu H.