web-dev-qa-db-ja.com

同じルーターの同じVLAN内の1つのVLANから別のVLANにIPをルーティングします

同じルーターの同じVLAN内の1つのVLANから別のVLANにIP(/ 32)をルーティングできますか?

例:

example_router#show version
Cisco IOS Software, c7600s72033_rp Software (c7600s72033_rp-ADVIPSERVICESK9-M), Version 12.2(33)SRD6, RELEASE SOFTWARE (fc3)

example_router(config)#ip route vrf EXAMPLE 10.10.10.3 255.255.255.255 vlan 2706
% For VPN or topology routes, must specify a next hop IP address if not a point-to-point interface
example_router(config)#
example_router(config)#ip route vrf EXAMPLE 10.10.10.3 255.255.255.255 vlan 2706 10.10.20.1
%Invalid next hop address (it's this router)

example_router#sh run in vlan 2705
Building configuration...

Current configuration : 339 bytes
!
interface Vlan2705
 ip vrf forwarding EXAMPLE
 ip address 10.10.10.1 255.255.255.0
 ip helper-address 10.0.0.1
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 no clns route-cache
end

example_router#sh run in vlan 2706
Building configuration...

Current configuration : 339 bytes
!
interface Vlan2706
 ip vrf forwarding EXAMPLE
 ip address 10.10.20.1 255.255.255.0
 ip helper-address 10.0.0.1
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 no clns route-cache
end

vrf config(@rnxrxからの要求):

example_router#show vrf EXAMPLE
    Name                             Default RD         Protocols   Interfaces
    EXAMPLE                          xxxxxx:yyyyyy      ipv4        Vl2705
                                                                    Vl2706
[output removed]

example_router#show running-config vrf EXAMPLE
Building configuration...

Current configuration : 7992 bytes
ip vrf EXAMPLE
 description mpls_vpn_EXAMPLE
 rd xxxxxx:yyyyyy
 route-target export xxxxxx:zzzzzz
 route-target import xxxxxx:yyyyyy
!
    [output removed]

!
router bgp xxxxxx
 !
 address-family ipv4 vrf EXAMPLE
  no synchronization
  redistribute connected
 exit-address-family
!
end

古いVLANを2つに分割する必要があり、1つの機器を2番目のVLANに配置する必要があります。クライアントがリモート接続して、IPアドレスを変更できるようになるまで、一時的に実行する必要があります。

そうでない場合、私が見る唯一のオプションは、クライアントと同期し、2番目のVLANでサブネット(例では10.10.10.1/24)を数分間構成することです。

ありがとうございました

1
Radu Maris

はい-これは有効であり、実際にはかなり一般的です。ルーターは、これらのインターフェース(および関連するルート)を、他のインターフェースから分離して保持される共通のルーティング/転送テーブルの一部として扱います(手動で相互インポートしない限り)。

1
rnxrx