web-dev-qa-db-ja.com

ノード0.12に `node-sass`を再インストールしてみますか?

Google Webスターターキットを使用したいのですが。 node.js v0.12.0、node-sassおよびgulpをインストールしました。

そして走った:

$ Sudo npm install

gulp serveとタイプすると、このエラーになります。

Using gulpfile ~/web-starter-kit/gulpfile.js Starting 'styles'... 'styles' errored after 93 ms 
Error: `libsass` bindings not found. Try reinstalling `node-sass`? at getBinding

私はnodeとgulpを再インストールしましたが、これは役に立ちません。

次に何をしますか?

256
Takagi Akihiro

あなたのノードのバージョンが4で、gulp-sassを使っているのなら、試してみてください。

npm uninstall --save-dev gulp-sass

npm install --save-dev [email protected]
385
Roma Rush

私はこの便利なコマンドを見つけました:

npm rebuild node-sass

rebuildのドキュメント

これは、新しいバージョンのノードをインストールするとき(またはノードバージョンを切り替えるとき)に便利で、すべてのC++アドオンを新しいnode.jsバイナリで再コンパイルする必要があります。

http://laravel.io/forum/10-29-2014-laravel-elixir-sass-error

339
denisazevedo

私はノード0.12.0を使ってこのエラーに遭遇し、それは既存の/node_modulesディレクトリを削除してnpm updateを実行することによって修正されました。

233
createbang

npm rebuild node-sassは私にエラーを出していました(Ubuntu)そしてnpm install gulp-sassはエラーを消さなかった。

GitHubで解決策を見てください。

npm uninstall --save-dev gulp-sass

npm install --save-dev gulp-sass

82
Pupper

私は同じ問題を抱えていた:

  • node-sassのインストール
  • インストールの最後にインストールが正常に完了したことを通知されている
  • その後、node-sassの再インストールを求められます。

解決法は node-sass version 2 をインストールすることです。これは現在のバージョンのnodeをサポートします。 https://github.com/sass/node-sass/issues/490#issuecomment-70388754 を参照してください。

実行します。

npm install [email protected]

次に再テストします。

$ npm ls node-sass
[email protected] /var/www/myapp
└── [email protected]

$ gulp sass
[09:48:42] Using gulpfile /var/www/myapp/gulpfile.js
[09:48:42] Starting 'sass'...
[09:48:42] Finished 'sass' after 15 ms
22
mikemaccana

Gulpを使っているのなら、試してみてください。

npm install gulp-sass

私は同じ問題を抱えていて、gulp-sassパッケージが問題でした。

19
georger

私は今日職場で同じ問題を抱えていた。

npm rebuild node-sass

私のために仕事をした

10
bin2hex

Nodeを0.10.36にダウングレードすると、node-sass githubページのこのスレッドごとに行う必要があります。 https://github.com/sass/node-sass/issues/490#issuecomment-70388754

あなたがNVMを持っているなら、あなたはただすることができます:

nvm install 0.10

そうでない場合は、NVMとその説明がここにあります。 https://www.npmjs.com/package/nvm

9
natepers

この答えは、OPとは少し直交していますが、

libsassバインディングはNode v4.0.0上のnode-sassラッパーで正しくインストールされません。質問と同じエラーメッセージが表示されました(Error: 'libsass' bindings not found. Try reinstalling 'node-sass')が、次のスクリプトを使用して、ノードv4.0.0をアンインストールし、nvmを使用してv0.12.7をインストールしました。

https://Gist.github.com/brock/5b1b70590e1171c4ab54

そして今libsassとnode-sassは正常に動作しています。

3
ericsoco

Gulp-sassのバージョンが1.3.0のときも同じ問題がありますが、2.1.0にアップグレードした後で修正してください。

2
Kos

ノードバージョンを切り替えた場合は、npm remove gulp-sassしてgulp-sassを再インストールすることもできます。

2
4m1r

私はすべての/node_modulesフォルダを削除してからnpm installを実行し、そしてそれはうまくいった。

ノードv5.5.0、npm 3.3.12があります

1
Florin Dobre

Nodejsをシステム全体でアップグレードしたために突然emberjs ^ 1.13アプリにこのメッセージが表示されないためにここに来た場合は、古いバージョンのember-cli-sassを使用していないことを確認してください。 Emberアプリ内でrm -rf node_modules bower_components dist tmpを作成し、次にpackage.jsonを適切なember-cli-sassバージョンに更新し、最後にnpm install --save-devを更新する必要があります。他の依存関係を再構築したり変更したりする必要なしに、これは私にとってそれを修正しました。

1
handwovensole

私は@Kosが持っていたのと同じ問題を抱えていましたが、何らかの理由で私が持っていた古いpackage.jsonファイルからgulp-sassパッケージを修正しなければなりませんでした。それはそれから現在依存関係をインストールし、そして今それはついにうまくいきます!

0
Shay

私にとって、この問題は私のビルドシステム(Travis CI)で私の.travis.ymlファイルでなんらかのダムをすることによって引き起こされました。事実上、私はnpm install の前に nvm use 0.12を呼び出していましたが、これはnode-sassの代わりに0.10のために0.12を構築することを引き起こしていました。私の解決策は単にnvm use.travis.ymlファイルのbefore_scriptセクションからnpm installセクションのbefore_installコマンドの前に移動することでした。

あなたのケースでは、あなたがgulpで始めているどんなプロセスでも(あなたが期待するものとは異なる)nodeの異なるバージョンを使っている可能性があります。

0
Alan H.

あなたは正しいバージョンを使う必要があります。試してください:

nvm use 0.12
0
alexfigtree

私の問題は、私がnode version 0.12.2を持つマシンを使っていたのですが、1.x.xバージョンのnpmを持っていたことです。必ずnpmのバージョンを更新してください。Sudo npm install -g npmこれが完了したら、既存のnode-sassを削除し、それをnpmで再インストールします。

0
k00k