web-dev-qa-db-ja.com

NpmインストールエラーEPERM操作は許可されていません

したがって、今日angular4プロジェクトを実行しようとしたとき、私の最初のエラーは:npm install eperm operation not permittedだから、ノードモジュールフォルダを削除して再試行することを考えました。しかし、npm installを実行すると、このエラーが発生しますnpm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "start"。 vscodeを閉じてインストールを試行し、ロックされていないことを確認しました。 npm cache cleanを試しましたが、エラーが発生しました。 enter image description here

今日の最新の闘争:

0 info it worked if it ends with ok
1 verbose cli [ 'C:\\Program Files\\nodejs\\node.exe',
1 verbose cli   'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-
  cli.js',
1 verbose cli   'install',
1 verbose cli   '-g',
1 verbose cli   '@angular/[email protected]' ]
2 info using [email protected]
3 info using [email protected]
4 verbose npm-session 2a0bb102467943cf
5 silly install loadCurrentTree
6 silly install readGlobalPackageData
7 error cb() never called!

管理結果: enter image description here

助言がありますか?

私のpackage.jsonは次のようになります。

{
 "name": "gamemanagement",
 "version": "0.0.0",
 "license": "MIT",
 "scripts": {
   "ng": "ng",
   "start": "ng serve",
   "build": "ng build",
   "test": "ng test",
   "lint": "ng lint",
   "e2e": "ng e2e"
  },
  "private": true,
  "dependencies": {
  "@angular/animations": "^5.0.1",
  "@angular/cdk": "^5.0.0-rc0",
  "@angular/common": "^5.0.1",
  "@angular/compiler": "^5.0.1",
  "@angular/compiler-cli": "^5.0.1",
  "@angular/core": "^5.0.1",
  "@angular/forms": "^5.0.1",
  "@angular/http": "^5.0.1",
  "@angular/material": "^5.0.0-rc0",
  "@angular/platform-browser": "^5.0.1",
  "@angular/platform-browser-dynamic": "^5.0.1",
  "@angular/platform-server": "^5.0.1",
  "@angular/router": "^5.0.1",
  "@ng-bootstrap/ng-bootstrap": "^1.0.0-beta.5",          
  "angular2-moment": "^1.7.0",
  "angular2-text-mask": "^8.0.4",  
  "angularfire2": "5.0.0-rc.3",
  "ap-angular2-fullcalendar": "^1.3.5",
  "bootstrap": "4.0.0-beta",
  "core-js": "^2.4.1",
  "firebase": "4.6.2",
  "font-awesome": "^4.7.0",
  "jquery": "^3.2.1",
  "moment": "^2.19.3",
  "ng2-date-picker": "^2.6.2",              
  "popper.js": "^1.12.9",
  "rxjs": "^5.4.2",
  "sweetalert2": "^7.0.9",
  "TypeScript": "^2.6.1",
  "zone.js": "^0.8.14"
 },
"devDependencies": {
"@angular/cli": "^1.5.3",
"@angular/compiler-cli": "^4.2.4",
"@angular/language-service": "^4.2.4",
"@types/jasmine": "~2.5.53",
"@types/jasminewd2": "~2.0.2",
"@types/node": "~6.0.60",
"codelyzer": "~3.2.0",
"jasmine-core": "~2.6.2",
"jasmine-spec-reporter": "~4.1.0",
"karma": "~1.7.0",
"karma-chrome-launcher": "~2.1.1",
"karma-cli": "~1.0.1",
"karma-coverage-istanbul-reporter": "^1.2.1",
"karma-jasmine": "~1.1.0",
"karma-jasmine-html-reporter": "^0.2.2",
"protractor": "~5.1.2",
"ts-node": "~3.2.0",
"tslint": "~5.7.0",
"TypeScript": "~2.3.3"
}

}

5
Troy Bryant

同じ問題がありました。キャッシュをクリーンにしてnpmを更新すると、すべてが正常になります。だから実行してみてください:

npm cache clean --force

npm install -g npm @ latest

7
svoychik

これには2つの解決策があります

  1. npm cache clean」を実行できます
  2. adminモードでコマンドプロンプトを実行します。
3
Deepak paramesh

エラーが発生しているモジュールを自分でインストールします。

多くの時間を費やし、考えられるすべての提案を試した後、エラーで言及された特定のモジュールをインストールすると、問題がグローバルに解決されることがわかりました。

例:npm ERR! {エラー:EPERM:操作は許可されていません。'Path\ Docume nts\AngularProjects\my-sample-app333\[email protected]\core-a3d1aa4 8\bundles\core.umd.js

実行:npm install -global @ angular/core

そしてそれは私のためにそれを修正しました!最後に!!

1

以下の設定を試してください。これが役立つことを願っています。

  • Node.jsを更新する

  • コマンドプロンプトでnpm cache cleanコマンド、管理者として試してください

以下を使用して削除する場合は、ノードのプロキシ設定を確認してください

npm config delete http-proxy
npm config delete https-proxy
1
tyaga001

100%確実

まず、プロジェクトフォルダを削除します。例:myapp1

次に-> npm cache clean --forceコマンドを実行します

以前にエラーが発生したコマンドを再入力します。

0

上記のすべてを試しましたが、うまくいきませんでした。
package.jsonのすべてのコンテンツをコピーし、ファイルを削除しました。次に、新しいファイルを作成してそこにすべてコピーし、package.jsonとして保存しました
それはすべてを修正しました

0
Jose R. Lopez

ちょうど試して npm cache clean迅速かつ簡単:)

0
Hanny Setiawan