web-dev-qa-db-ja.com

npmパッケージのグローバルインストールで「npm ERR!code EPEERINVALID」を取得

グローバルパッケージをインストールするたびに、このエラーが発生します。

エラー:-npmパッケージのグローバルインストール

例:-

[email protected]:~$ Sudo npm install -g jshint

/usr/bin/jshint -> /usr/lib/node_modules/jshint/bin/jshint
npm ERR! Linux 3.19.0-25-generic
npm ERR! argv "node" "/usr/local/bin/npm" "install" "-g" "jshint"
npm ERR! node v0.10.25
npm ERR! npm  v2.13.2
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package [email protected] does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer [email protected] wants [email protected]~0.10.0
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.9
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.12.8
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.9
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.9
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.9
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.9
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.9

今まで試したこと

グローバルカルマとその関連モジュールを更新しようとしましたが、うまくいきませんでした。カルマモジュールのアンインストールも試みましたが、問題は解決しません。

Sudo npm uninstall -g  karma grunt-karma karma-html2js-preprocessor  karma-mocha karma-phantomjs-launcher karma-script-launcher  karma-jasmine  karma-requirejs karma-coffee-preprocessor
18
Robins Gupta

コマンドを使用してnpmを更新する

npm install npm -g

次に、キャッシュをクリーンアップします

npm cache clean

次に、要件に従ってパッケージをインストールします。これがすべてに役立つことを願っています。

9
Prashant

NPMの修正ではありませんが、この問題に関する私の場合の回避策(Ubuntu 16.04を使用)は、yarnをインストールし、「npm install」ではなく「yarn install」を実行することでした。

0
Elijah Lofgren

以前使用していたフレーズではなく、単一のWordでプロジェクトに名前を付けることで問題を修正しました。

0
Tendai Katsande