web-dev-qa-db-ja.com

Npm行方不明ピアの依存関係を修正する方法

以下のピア依存関係エラーを修正する方法がわかりません。

[email protected]:~/Documents/git/py-cli_build_tools$ Sudo npm -g list | grep eslint    
├─┬ [email protected]
├─┬ [email protected]
├─┬ [email protected]
│ └── [email protected]
├─┬ [email protected]
├─┬ [email protected]
│ ├─┬ [email protected]
│ ├─┬ [email protected]
├─┬ UNMET PEER DEPENDENCY [email protected]
├─┬ [email protected]
npm ERR! peer dep missing: [email protected]^2.2.3, required by [email protected]

ご覧のとおり、私は[email protected]これは間違いなく満たされます^2.2.3が必要

eslint-config-airbnb。ただし、このようなエラーメッセージは表示されます。そのような問題を解決するためのアイデアはありますか?

15
Mond Wan

バージョン^^2.2.3の意味を誤解しています。

このリンク を読んだ後、^2.2.3>=2.2.3 <3.Xを意味します。これが、npmが警告をスローする理由です。

また、以下はpeer-dependenciesに関するリンクです

16
Mond Wan