web-dev-qa-db-ja.com

package.jsonの依存関係で「次」とは正確に何を意味しますか?

Package-jsonの依存関係でnextはどういう意味ですか?

"dependencies": {
  "react": "^15.4.2",
  "react-dom": "^15.4.2",
  "react-router-dom": "next"
}
23
zok

具体的には、ドキュメントによると、これは有用だとわかりました。

デフォルトでは、npmは最新のタグを使用してパッケージの現在のバージョンを識別し、npm install(@または@指定子なし)は最新のタグをインストールします。 通常、プロジェクトは、安定したリリースバージョンには「最新」タグのみを使用し、プレリリースなどの不安定なバージョンには他のタグを使用します

次のタグは、一部のプロジェクトで次のバージョンを識別するために使用されます。

デフォルトでは、最新以外のタグはnpm自体に特別な意味を持ちません。

そのため、たとえば、npm自体がnpm ERRを生成することに関連するいくつかの問題がありました!エラー:EACCES:パッケージのインストールで許可が拒否されました。これは、以前のバージョンのnpm(5.4.0から)に戻すことで最初に修正しました。

npm install -g [email protected]

しかし、npmはdoesがそれらのパッケージの1つであり、ディストリビューションで「next」タグを使用します。 「安定版」、次を実行することもできます:

npm install -g [email protected]

5.5.1をインストールしたもの

ランニング: npm show npm versions --jsonは、次のバージョン履歴を表示して、インストールされたものを正確に把握します。[... "5.3.0"、 "5.4.0"、 "5.4.1"、 "5.4.2"、 "5.5.0"、 " 5.5.1 "]

13
chrisz