web-dev-qa-db-ja.com

SSL:DockerコンテナでのCERTIFICATE_VERIFY_FAILEDエラー

Easy_install pipを実行すると、次のエラーメッセージが表示されます。

[email protected]:/# easy_install pip
Searching for pip
Reading https://pypi.python.org/simple/pip/
Download error on https://pypi.python.org/simple/pip/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590) -- Some packages may not be found!
Couldn't find index page for 'pip' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading [--https link here, like above--]
Download error on https://pypi.python.org/simple/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590) -- Some packages may not be found!
No local packages or download links found for pip
error: Could not find suitable distribution for Requirement.parse('pip')

これは、ubuntu:latestで実行されるDockerコンテナーで実行されます。私はopensslのもの(httpsリンク)を実行できないという事実に傾いていますが、完全にはわかりません。誰かが解決策やトラブルシューティングの方法を持っているなら、私は見つけたいです。

ありがとう。

5
cid

追加RUN apt-get install ca-certificates私のDockerfileは私のために働いた。

3
Matt

以下のパッケージを新たにインストールすると、問題が解決しました

apt-get -yqq install build-essential libssl-dev libffi-dev python3-pip python3-dev gnupg
0
Shams

解決済み:

Dockerfileに以下を追加しました。

RUN mkdir /etc/pki
RUN mkdir /etc/pki/tls
RUN mkdir /etc/pki/tls/certs
RUN apt-get install wget
RUN wget http://curl.haxx.se/ca/cacert.pem
RUN mv cacert.pem ca-bundle.crt
RUN mv ca-bundle.crt /etc/pki/tls/certs
0
cid