web-dev-qa-db-ja.com

デフォルトを設定する方法Ruby RVMのバージョン?

Ubuntu 11。

私は次のことを行います:

_$ rvm --default use 1.9.2_と私は得る:

_Using /home/md/.rvm/gems/Ruby-1.9.2-p180_それは良いことです。

しかし、新しいターミナルウィンドウを開くと、次のようになります。

_$ Ruby -v_

Ruby 1.8.7 (2010-08-16 patchlevel 302) [i686-linux]

38
Michael Durrant

(非インタラクティブシェルがRVMにアクセスできるようにするために)bashrcにRVMソース行を配置する場合、.bash_profileの最後の行として.bash_profileから.bashrcをソースする必要があります。

if [ -f "$HOME/.bashrc" ]; then
  source $HOME/.bashrc
fi

これはあなたが持っていることを前提としています

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm"

$ HOME/.bashrcで。これは、対話型/ログインシェルと非対話型シェルの両方がRVMを正しく検索してロードできるようにするための良い方法です。マルチユーザーインストールは、/ etc/profile.d/rvm.shファイルを介して同じことを実現します。

その後、デフォルトのRubyを使用して定義するのに問題はないはずです。

rvm 1.9.2 --default

または

rvm use [email protected] --default

「デフォルト」または「グローバル」の宝石セットを汚染しないように、使用するデフォルトの宝石セットを定義することをお勧めします。

非対話型シェルを使用している場合、それらは一般的にSH互換モードで動作することに注意してください。

BASH_ENV="$HOME/.bashrc"

$ HOME/.profileでRVMをロードするか、スクリプト内で直接設定します。これは、bashがSHモードで動作している場合、SHがこれらのファイルを使用しないため、.bash_profileまたは.bashrcを直接ロードせず、bashはSHシェルのロードおよび実行プロセスを模倣しようとするためです。

43
ddd

「rvmリスト」を実行して、どのRubyインストールしたバージョンかを確認します。

1つのターミナルセッションでのみバージョンを変更する場合は、これを実行します。

rvm use 1.8.7

このユーザーアカウントのデフォルトバージョンを選択する場合は、次の操作を行います。

rvm use --default 1.9.2

見る:

rvm use --help

このRailsCastも参照してください。

http://railscasts.com/episodes/200-Rails-3-beta-and-rvm

http://beginrescueend.com/

10
user985823

パーティーに遅刻-とにかく。

デフォルトRubyバージョン:rvm --default use 1.9.2

ただし、GemfileをターゲットRubyに更新する必要があります。これは、RVMがそのファイルを参照して、terminalを開いたときに作業中のRubyバージョンを選択するためです。 Rubyバージョン。

2
user1322092

Rubyのデフォルトバージョンを変更するには:

In bunt

Ubuntuのデフォルトのターミナルに移動し、指示に従います:

1) Edit -> Profile Preferences
2) Select "Title and Command"
3) check "Run command as a login Shell"
4) restart terminal

その後、次のコマンドを実行します。

rvm --default use [email protected]_name

0
indb