web-dev-qa-db-ja.com

Ruby rvmを使用してバージョンを更新した後、パスがRVMに設定されました]という警告メッセージを受信しました

最近、警告メッセージのためにRubyバージョンを更新しようとしました(以下を参照)。

Iterm2を起動すると、次の警告メッセージが表示されます。

Warning: PATH set to RVM Ruby but GEM_HOME and/or GEM_PATH not set, see:
    https://github.com/wayneeseguin/rvm/issues/3212

この警告を解決しますか?これは私の作業に実際には影響していませんが、少し不安です。

ご参考までに:
1。私は走ったと信じていたrvm get stable最新のRubyバージョンを取得します。
2。これは、最初に解決しようとしていた警告メッセージですが、まだ解決されていません。

warning: parser/current is loading parser/Ruby21, which recognizes
warning: 2.1.5-compliant syntax, but you are running 2.1.2.

1を使用しています。Mac OS X 2. iterm2および3 .oh-my-zshシェル

42
echo

オプション--Railsでrvmをインストールしているときに、oh-my-zshで同じ問題が発生しました。この警告がありました。

このソリューションは私のために機能します:Open .zshrcファイル、およびPATH行の検索

変化する

export PATH=/path/to/something

export PATH="$PATH:/path/to/something"

保存してsource ~/.zshrc、それから動作しました。

114
ymin

〜/ .zshrcファイルでUser configurationの後に次のような行がある場合:

#export PATH = "/ Users/robinwen/.rvm/gems/[email protected]/bin:/Users/robinwen/.rvm/gems/[email protected]/bin:/ Users/robinwen/.rvm/rubies/Ruby-1.9.3-p551/bin:/Users/robinwen/.rvm/bin:/ usr/local/git/bin:/ sw/bin:/ usr/local/bin:/usr/local:/ usr/local/sbin:/ usr/local/mysql/bin:/ usr/local/bin:/ usr/bin:/ bin:/ usr/sbin:/ sbin:/ usr/local/bin/"

この行をコメント化し、次の行を追加する必要があります。

export PATH = $ PATH:$ HOME/.rvm/bin#スクリプト用にRVMをPATHに追加

がんばろう!

10
robinwen

@yminのソリューションに追加します。私にとっては、誰が_rvm listと現在のRubyが選択されていなかったため、手動でRubyすなわちrvm use Ruby-2.1.x、次にzshrcパスを修正してrvm get stable

5
maxhungry

2014年12月19日、Sudo rvmは、rootユーザーのデフォルトシェルが サポートされていない の場合にこれらのPATH警告を表示します。

この場合、Sudo rvm解決策は rvmsudo を使用することです。

3
leoj

同じ質問があります

私の解決方法は追加です

source /etc/profile.d/rvm.sh

.zshrc内

ソース.zshrcは大丈夫です

頑張ってね!

1
张华轩

[[-s "$ HOME/.rvm/scripts/rvm"]] && source "$ HOME/.rvm/scripts/rvm"を下部ではなく〜/ .zshrcの上部に追加した後、これが解決したことを確認できます。私にとっての問題。

1
JayKan

ここで同じ問題、以下のコードを~/.zshrcに追加してください。

export GEM_HOME="$GEM_HOME:$HOME/.rvm/bin"
export GEM_PATH="$GEM_PATH:$HOME/.rvm/bin"

そしてsource ~/.zshrc

1
idsbllp