web-dev-qa-db-ja.com

TypeScriptをnpmで最新バージョンにアップデートするにはどうすればいいですか?

現在私のマシンにはTypeScript 1.0.3.0がインストールされています。
最新のもの、つまり2.0に更新したいです。

Npmでこれを行う方法?

130
blueMoon

npm install -g [email protected]を試してください。最新の修飾子なしで、インストールの代わりにnpm updateを使うこともできます。

233
eavidan

Windowsの場合 openコマンドプロンプト(cmd.exe)

おすすめ:

npm install -g [email protected]

これは最新のTypeScriptバージョンをインストールします まだインストールされていなければ そうでなければ 現在のインストールを最新バージョンに更新します。

そして verify どのバージョンがインストールされているか

tsc -v

enter image description here


TypeScriptがすでにインストールされている場合は、次のコマンドを使って最新バージョンにアップデートすることもできますが、コメンテーターが報告したとおり、次のコマンドは最新にアップデートされないことを確認します。

npm update -g [email protected]
54
Legends

Windowsを使用していてVisual Studioをインストールしている場合は、PATHに古いバージョンのTypeScriptを指しているものがあるかもしれません。私のPATHから "C:\ Program Files(x86)\ Microsoft SDKs\TypeScript\1.0 \"フォルダを削除すると(またはこのフォルダを削除すると名前を変更すると)、最新のnpmグローバルにインストールされたTypeScript版のtscが動作するようになります。

31
Veener

あなたは単にnpm install -g [email protected]とタイプすることによってこれを行うことができるはずです。これでうまくいかない場合は、どのバージョンのnodeとnpmを使用しているのか疑問に思い始めます。これらを見つけるためにnode -vnpm -vを試してください。あなたは、ノード> 4.5とnpm> 3にいるはずです。

11
Andrew Reid

# npm update -g TypeScriptコマンドを使うだけです
グローバルにインストールされたすべてのモジュールを更新するには、次のコマンドを使用します。# npm update -g

1
Pascal Tovohery

非常に古いNodeJSでWindowsを使用している場合は、コントロールパネル(Win7)または以前のSettings/Apps(Win10)で以前のNodeJおよびNVM(Node Version Manager)をアンインストールします。それらがPATHから削除されていることを確認してください。

NodeJSを再インストールします。 https://nodejs.org/en/download NPMもインストールされます。

TypeScriptをグローバルにインストールします。

npm install -g TypeScript

インストールを確認します。

tsc -v
0
Donato Szilagyi

npm の場合:あなたは実行することができます:

npm update -g TypeScript

デフォルトでは、最新バージョンがインストールされます。

yarn の場合は、次のように実行できます。

yarn upgrade TypeScript

あるいは、元のバージョンを削除してyarn global remove TypeScriptを実行してからyarn global add TypeScriptを実行すると、デフォルトで最新バージョンのTypeScriptもインストールされます。

詳しくは yarn docs をご覧ください。

0
Little Roys

プロンプトでコマンド「where」を使用して、パスで現在の実行可能ファイルを見つけます

C:\> where tsc
C:\Users\user\AppData\Roaming\npm\tsc
C:\Users\user\AppData\Roaming\npm\tsc.cmd
0
impactro