web-dev-qa-db-ja.com

docker-ce:依存:libseccomp2(> = 2.3.0)が、2.2.3-3ubuntu3がインストールされる

ubuntuマシンにdockerをインストールし、このチュートリアルに従っているim https://docs.docker.com/engine/installation/linux/docker-ce/ubuntu/#extra-steps-for-aufs

sudo apt-get install -y docker-ceを実行すると、マシンにdockerがインストールされず、次のエラーが表示されます

$ Sudo apt-get install -y docker-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 docker-ce : Depends: libseccomp2 (>= 2.3.0) but 2.2.3-3ubuntu3 is to be installed
E: Unable to correct problems, you have held broken packages.

Sudo apt-get install libseccomp2を実行すると、システムに既にインストールされていますが、マシンにdockerをインストールしようとすると、同じエラーが表示されます。

ここに私のUbuntu OSの情報があります

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS"
NAME="Ubuntu"
VERSION="16.04.2 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.2 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial
14
Muhammad Ateek

Docker-ceバージョン18をインストールするときに同じ問題が発生します。nvidia-dockerは18を超えるdockerバージョンしかサポートしないため、aptitudeを使用して古いバージョンをインストールしません。

解決策は非常に簡単です。

Sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
Sudo apt-get update

その後、コマンドSudo apt-get install docker-ceを使用して、libseccomp2バージョンの競合の問題を解決できます。

参照: https://Gist.github.com/mingrui/187f0e629007443268ce8c1414012ed5

16
ChenYang

お元気ですか?

私はLinux Mint(Ubuntu Xenial)にいます。

正確なエラーがありました。

解決策はこちらから:
https://docs.docker.com/install/linux/docker-ce/ubuntu/#install-docker-ce-1

次のような特定のバージョンが必要だと思います(xenialバージョンを選択します):

[email protected]:~$ Sudo -i
[Sudo] password for patrikx3: 
[email protected]:~# apt-cache madison docker-ce
 docker-ce | 17.12.1~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.12.0~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.09.1~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.09.0~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.06.2~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.06.1~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.06.0~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.03.2~ce-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.03.1~ce-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.03.0~ce-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
[email protected]:~# apt install docker-ce=17.03.2~ce-0~ubuntu-xenial
Reading package lists... Done
Building dependency tree       
Reading state information... Done
docker-ce is already the newest version (17.03.2~ce-0~ubuntu-xenial).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~# 

純粋なubuntuでは機能していませんでした。

11
Patrik Laszlo

私はubuntu 16でも同じ問題を抱えていました。ほとんどすべての解決策を試しました。次のコマンドを実行してください。

Sudo apt install docker.io

しかし、私は今、最新バージョンがdocker-ceを使用してインストールしていることに気付きました。 docker.ioは古いバージョンです。ただし、問題を解決するには、互換性のあるバージョンを見つける必要があります。

私にとっては、バージョン名を指定して次のコマンドを実行しています。

apt install docker-ce=17.12.0~ce-0~ubuntu

次のコマンドを使用すると、使用可能なバージョンのリストが表示され、上から下に次々に試すことができます。

apt-cache madison docker-ce

これで問題が解決することを願っています。

10
Bhargav Patel

Linux mint 18.3でも同じ問題があります。manualをインストールしました: http://launchpadlibrarian.net/344879847/libseccomp2_2.3.1-2.1ubuntu2~16.04.1_AMD64.deb

i古いバージョンを削除しない

libseccomp2をインストールすると、docker-ceはacharmのように動作します。

3

私は私たちのオペレーションからubuntuサーバーを取得しますが、同じ問題があります

ファイルよりも掘り始めたとき/ etc/apt/sources.listはパッケージリポジトリへの壊れたURLです

私の場合は

deb http://ubuntu-mirror/ubuntu/ xenial universe

各行の変更後buntu-mirrorde.archive.ubuntu.comが得られます/ etc/apt/sources.list file URL付き

deb http://de.archive.ubuntu.com/ubuntu/ xenial universe

それから

Sudo apt update
Sudo apt upgrade
Sudo apt install -y docker-ce

追伸opsは古い10.04を16.04に更新し、更新後のリポジトリは破損しました

Ubuntu 16.04.1以降では、Xenialアップデートのバージョン2.3にlibseccomp2が存在します。インストールするには、チェック済みかどうかを確認します。

システム設定->ソフトウェアとアップデート->アップデート:推奨アップデート

次に:

Sudo apt update
Sudo apt upgrade
1
Radek

同様の問題がありました。私はaptitudeの代わりにaptを使用してそれを乗り越えました:

$ Sudo aptitude install docker-ce

解決策をスキップし、競合する依存関係を解決すると主張するものを受け入れます。

The following actions will resolve these dependencies:

     Install the following packages:                    
1)     docker-ce [17.04.0~ce-0~debian-stretch (stretch)]



Accept this solution? [Y/n/q/?] y

aptitudeに作業を任せると、docker-ce

$ docker --version
Docker version 17.04.0-ce, build 4845c56
1
ritiek